Couldn't connect Control Surface


#1

After registering and installing the new update of VideoSync V0.7.2. I can’t find Videosync in the list of MIDI Sync in Ableton’s preferences. I installed the Control Interface and restarted Ableton several times, my Macbook as well.

All the best,
Maurijn


#2

Hi Maurijn,

Were you able to use the Control Surface in earlier versions, or is 0.7.2 the first release you’re using?

If this is the first release you’re using, the Control Surface should be present in the list of ‘MIDI Control Surfaces’. You can find a screenshot of the window in our manual.

Hope this helps!

Best,
Hidde


#3

Thanks for the quick reply,

I used the V0.6.2 version earlier, with succes.
Ever since I installed V0.7.2 the control surface won’t show up in the preferences.

Video of my installation: https://youtu.be/_NQvDFpUpyk

Thanks,
Maurijn


#4

Thank you for the video!

There have been some changes in the control surface since 0.6.2. I think there is an error while trying to load the control surface which makes it not show up in the preferences.

To fix this, I need to know which version of Ableton Live you’re running, and I need you to send me Live’s Log.txt file.

To find the log file, please follow the following steps:

  • In Finder, you’ll find a menu item called Go to Folder... under the Go menu in the main menu.
  • Go to the folder ~/Library/Preferences/Ableton/.
  • Here you’ll find a folder for each Live version you used. Make sure to choose the folder for the version you’re running.
  • The folder will contain a file called Log.txt.
  • Send this file to [email protected]

#5

Hi Maurijn,

Thanks for the log file. It looks like the control surface did not load because of a missing extension in the Python code. However, this should be available on all systems. Could you let me know which Python version is available on your computer? You can do this by launching Terminal on your computer and executing the following command: python --version.

Best,
Hidde


#6

The issue was resolved by a fix in Videosync 0.7.4 and updating Ableton Live from 9.5 to 9.7.5.


#7