Bad Number errors in Max window


#1

Hi there!

I’m trying to use TrackGrabber to automate volume faders in Live. I have float OSC messages ("/ch/01/mix/fader 0.xxxxx") coming in and displaying correctly in the GrabberReceiver on the master track.

In the TrackGrabber device, I can see the address in the “recent incoming” dropdown but it doesn’t fill the textbox when I select it. If I type it in manually nothing happens. I’m getting a lot of “/ch/01/mix/fader: bad number” appearing in the Max window. The other address boxes in the device have “0.” in them. On the GrabberSender plugin, the IP/port fields default to “127.” or “0.” which struck me as a bit weird.

I’m using Live 9.7.7 with Max 8.0.0, Livegrabber 4.1.

Thanks!


#2

Hi fastfourier,

Thanks for letting us know.

I tried to reproduce this but unfortunately I couldn’t. When I use the following Max patch to send:


----------begin_max5_patcher----------
405.3ocmSssaCBCC8Y3qHJZOxZIPus8qLMUE.2tTAInjPGSU8eeAGnsasqEs
WbjOww93icNDFPyTsfgRdk7FIH3PXP.B0ADz6GPq3s4kbCFFcSoR1TQi7WUy
s4eHjaWqgbqOMySlDGQRm0YmG2YSbHj26egpwVBV6W0fObJMhPy3xszSgrQo
q3X1VLTFMX.okaEJ43Kkn.YrJa2yyOSXMuBrfdMH4YkHIh6uy0WBoibXixNC
5oLhlzAdLLryDMREqBLF9VXfAVnEoOcZ9GSiYSqDsS2vK.M4I1Ck0kocVFiM
Bc8zU2U896Ldg7kRukDkbSIh8OjHI7oqLWoPME0NhWPXIKm3FuSXDVZ5xGJR
r3WvizUW0S2UJty6tPKXzwutDegVf4hVJj+9+F1Gc3+TfLpFc9vvreGlblQE
fwJjXibQLo9Xt4HXr0IcD0gcUc7sGutdOnM8AikvMo2ozctqhPWgz6he6nZX
uXHdOBW6FqV2roQizh1tXF0+Tk6ahrQzul4ZNWIwsHo6Ssol66CbYK7X32vB
tPxU
-----------end_max5_patcher-----------

and using this set to receive: http://showsync.info/livegrabber/livegrabber-fastfourier-report-test-Project.zip,

it works as expected for me, using Live 9.7 with Max 8.0.0, Livegrabber 4.1

Would you be able to check if there are any errors in your Max window (right-click MFL plugin title bar, select ‘Open Max Window’)?

Best,
Mattijs


#3

Hi Mattjs! Thanks for your reply and the test ableton set! It didn’t work for me unfortunately, I made a video with the Max window open while I am adding the plugins to a blank live set.

https://youtu.be/_7myGGVuI6k

I didn’t mention in my first post that the activity “lights” in the TrackGrabber plugin don’t illuminate when moving the fader, even though it says “linked to track x”.

Before recording the video I removed all the preferences and library files for both Max and Live, so I’m starting from “factory” (as close as I can anyway).

Many thanks for your help!


#4

Thanks for your detailed reply and the video, that really helps.

It looks like this is the result of a known bug around behaviour of pattr in Max 8.0.0 that will be fixed in the next release of Max.

Until that time it is advised to keep working with Max 7 in Ableton Live 9 and with the embedded Max 8 version (which is not the real Max 8) in Live 10.

Hope that helps,
Mattijs


#5

Hi Mattjs,

I went back to Max 7 and it’s working now!

Many thanks!


#6

Happy to hear that, fastfourier! Let us know if Max 8 works for you once 8.0.1 is out.